Laravel по-русски

Русское сообщество разработки на PHP-фреймворке Laravel.

Ты не вошёл. Вход тут.

#1 10.08.2017 03:05:39

Проблема с установкой пакета с Github

Версия laravel: 5.4.32

Нашел на Github авторизацию через WG для laravel 5: Wargaming authentication for laravel 5
Приступаю к установке, в  composer.json добавил "rguedes/laravel-wargaming-auth": "2.*"

{
    "name": "laravel/laravel",
    "description": "The Laravel Framework.",
    "keywords": ["framework", "laravel"],
    "license": "MIT",
    "type": "project",
    "require": {
        "php": ">=5.6.4",
        "laravel/framework": "5.4.*",
        "laravel/tinker": "~1.0",
	"rguedes/laravel-wargaming-auth": "2.*"
    }
....
....

Выполняю composer install
И выдается ошибка

Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package rguedes/laravel-wargaming-auth could not be found in any version, there may be a typo in the package name.

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Не в сети

#2 10.08.2017 09:11:33

Re: Проблема с установкой пакета с Github

В Packagist нет такого пакета, отсюда и ошибка. Видимо автор удалил его оттуда. Я бы связался с автором и задал ему вопрос по поводу пакета.

Или ты можешь сделать форк пакета на GitHub и добавить его в Packagist, чтобы иметь возможность устанавливать пакет с помощью composer.

В сети

#3 10.08.2017 13:12:27

Re: Проблема с установкой пакета с Github

Или в composer.json добавить раздел repositories с указанием нужного репозитория на гитхабе.

Изменено Sergant210 (10.08.2017 13:12:56)

Не в сети

#4 10.08.2017 14:19:54

Re: Проблема с установкой пакета с Github

Можно и так, но я бы связался с автором и, если автор не ответит, то сделал бы форк. Так будет хоть какой-то контроль. Если автор пакета убрал его с Packagist (может какие-то веские причины были?), то он точно также может и с GitHub его удалить.

В сети

#5 11.08.2017 10:29:32

Re: Проблема с установкой пакета с Github

Связался с автором, он помог. Но после установки и публикации файла конфигурации, у меня перестали выполнятся php artisan
выдает ошибку

PHP Fatal error:  Uncaught ReflectionException: Class log does not exist in /var/www/html/vendor/laravel/framework/src/Illuminate/Container/Container.php:734
Stack trace:
#0 /var/www/html/vendor/laravel/framework/src/Illuminate/Container/Container.php(734): ReflectionClass->__construct('log')
#1 /var/www/html/vendor/laravel/framework/src/Illuminate/Container/Container.php(629): Illuminate\Container\Container->build('log', Array)
#2 /var/www/html/vendor/laravel/framework/src/Illuminate/Foundation/Application.php(697): Illuminate\Container\Container->make('log', Array)
#3 /var/www/html/vendor/laravel/framework/src/Illuminate/Container/Container.php(849): Illuminate\Foundation\Application->make('log')
#4 /var/www/html/vendor/laravel/framework/src/Illuminate/Container/Container.php(804): Illuminate\Container\Container->resolveClass(Object(ReflectionParameter))
#5 /var/www/html/vendor/laravel/framework/src/Illuminate/Container/Container.php(773): Illuminate\Container\Container->getDependencies(Array, Array)
#6 /var/www/html/vendor/ in /var/www/html/vendor/laravel/framework/src/Illuminate/Container/Container.php on line 734

Не в сети

#6 11.08.2017 10:36:04

Re: Проблема с установкой пакета с Github

Разобрался, не было кавычки в конфигурационном файле. Из-за одной кавычки всё пошло по пиз... smile

Не в сети

Подвал раздела